PHPIPAM upgrade 1.3.2 to 1.4 error and fix

Tonight I was upgrading PHPIPAM from version 1.3.2 to version 1.4 and ran into an issue.  After doing a git pull I logged into the web GUI and went to upgrade the database.  I receive the following error.

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'dbversion' in 'field list'

Since I run Webmin, I logged into Webmin and ran the following command on my database

alter table settings add column dbversion tinyint(1);

Once that was executed I was able to go back into the web GUI and upgrade the database.  I ended up with two theme errors which were easily fixed.

PHPipAM Upgrade issues and fix

This content is for Patreon subscribers of the j2 blog. Please consider becoming a Patreon subscriber for as little as $1 a month. This helps to provide higher quality content, more podcasts, and other goodies on this blog.
To view this content, you must be a member of Justin Wilson's Patreon at $0.01 or more
Already a qualifying Patreon member? Refresh to access this content.